#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Mr?s?\.)[A-Za-z]*[A-Za-z-]+"
Local $sString = "</a018620183616546 >" & @CRLF & _
                "<src =456564565545225552222.2222222 >" & @CRLF & _
                "558-5548-542" & @CRLF & _
                "Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh" & @CRLF & _
                "suyan8019@gmail.com" & @CRLF & _
                "563822998@qq.com" & @CRLF & _
                "suya64@yahoo.com" & @CRLF & _
                "su_yan@wang.com" & @CRLF & _
                "3.14152655878777&*#example" & @CRLF & _
                "Mrs.susanwillcometo jointheparty.Mr.zhanglovehisbrother" & @CRLF & _
                "Ms.wangsh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")