const regex = new RegExp('(Mr?s?\\.)[A-Za-z]*[A-Za-z-]+', 'gm')
const str = `</a018620183616546 >
<src =456564565545225552222.2222222 >
558-5548-542
Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh
suyan8019@gmail.com
563822998@qq.com
suya64@yahoo.com
su_yan@wang.com
3.14152655878777&*#example
Mrs.susanwillcometo jointheparty.Mr.zhanglovehisbrother
Ms.wangsh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}