import Foundation
let pattern = #"(Mr?s?\.)[A-Za-z]*[A-Za-z-]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
</a018620183616546 >
<src =456564565545225552222.2222222 >
558-5548-542
Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh
suyan8019@gmail.com
563822998@qq.com
suya64@yahoo.com
su_yan@wang.com
3.14152655878777&*#example
Mrs.susanwillcometo jointheparty.Mr.zhanglovehisbrother
Ms.wangsh
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)