using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Mr?s?\.)[A-Za-z]*[A-Za-z-]+";
string input = @"</a018620183616546 >
<src =456564565545225552222.2222222 >
558-5548-542
Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh
suyan8019@gmail.com
563822998@qq.com
suya64@yahoo.com
su_yan@wang.com
3.14152655878777&*#example
Mrs.susanwillcometo jointheparty.Mr.zhanglovehisbrother
Ms.wangsh";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}