import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Mr?s?\\.)[A-Za-z]*[A-Za-z-]+";
final String string = "</a018620183616546 >\n"
+ "<src =456564565545225552222.2222222 >\n"
+ "558-5548-542\n"
+ "Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh\n"
+ "suyan8019@gmail.com\n"
+ "563822998@qq.com\n"
+ "suya64@yahoo.com\n"
+ "su_yan@wang.com\n"
+ "3.14152655878777&*#example\n"
+ "Mrs.susanwillcometo jointheparty.Mr.zhanglovehisbrother\n"
+ "Ms.wangsh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}