re = /(Mr?s?\.)[A-Za-z]*[A-Za-z-]+/m
str = '</a018620183616546 >
<src =456564565545225552222.2222222 >
558-5548-542
Youregularexpres5644-6555siondosnotmatchthesubjecstring/bin/tcsh
suyan8019@gmail.com
563822998@qq.com
suya64@yahoo.com
su_yan@wang.com
3.14152655878777&*#example
Mrs.susanwillcometo jointheparty.Mr.zhanglovehisbrother
Ms.wangsh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end