#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\/]*\d[^\/]*\/?"
Local $sString = "/text/~col-345/text/" & @CRLF & _
"/text/eny/~col-4545/" & @CRLF & _
"/text/eny/col/" & @CRLF & _
"/text/~col-/text/" & @CRLF & _
"/text/eny/2~col-/" & @CRLF & _
"/text/eny/col3/" & @CRLF & _
"https://regex101.com/r/8mqh4V/1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")