re = /[^\/]*\d[^\/]*\/?/
str = '/text/~col-345/text/
/text/eny/~col-4545/
/text/eny/col/
/text/~col-/text/
/text/eny/2~col-/
/text/eny/col3/
https://regex101.com/r/8mqh4V/1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end