use strict;
my $str = '/text/~col-345/text/
/text/eny/~col-4545/
/text/eny/col/
/text/~col-/text/
/text/eny/2~col-/
/text/eny/col3/
https://regex101.com/r/8mqh4V/1';
my $regex = qr/[^\/]*\d[^\/]*\/?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}