using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\/]*\d[^\/]*\/?";
string input = @"/text/~col-345/text/
/text/eny/~col-4545/
/text/eny/col/
/text/~col-/text/
/text/eny/2~col-/
/text/eny/col3/
https://regex101.com/r/8mqh4V/1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}