import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\/]*\\d[^\\/]*\\/?";
final String string = "/text/~col-345/text/\n"
+ "/text/eny/~col-4545/\n"
+ "/text/eny/col/\n"
+ "/text/~col-/text/\n"
+ "/text/eny/2~col-/\n"
+ "/text/eny/col3/\n"
+ "https://regex101.com/r/8mqh4V/1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}