$re = '/[^\/]*\d[^\/]*\/?/';
$str = '/text/~col-345/text/
/text/eny/~col-4545/
/text/eny/col/
/text/~col-/text/
/text/eny/2~col-/
/text/eny/col3/
https://regex101.com/r/8mqh4V/1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);