const regex = /[^\/]*\d[^\/]*\/?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\\/]*\\d[^\\\/]*\\\/?', 'g')
const str = `/text/~col-345/text/
/text/eny/~col-4545/
/text/eny/col/
/text/~col-/text/
/text/eny/2~col-/
/text/eny/col3/
https://regex101.com/r/8mqh4V/1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}