#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b(crayons|cars|camels)\b(?:[^a-z\n]*([a-z]*)[^a-z\n]*([a-z]*))"
Local $sString = "there are many crayons, in the blue box crayons that are'," & @CRLF & _
"cars! i like a lot of sports cars because they go fast'," & @CRLF & _
"the camels, in the middle east have many camels to ride," & @CRLF & _
"some more example with edge case camels" & @CRLF & _
"some hyphense words see-camels should it match ??" & @CRLF & _
"hello test string cars one" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")