$re = '/\b(crayons|cars|camels)\b(?:[^a-z\n]*([a-z]*)[^a-z\n]*([a-z]*))/mi';
$str = 'there are many crayons, in the blue box crayons that are\',
cars! i like a lot of sports cars because they go fast\',
the camels, in the middle east have many camels to ride,
some more example with edge case camels
some hyphense words see-camels should it match ??
hello test string cars one
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);