#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(pensionsrü\w*)\s[\D]*(\d*[.,]?\d*[,.]?\d*\s?[€%])"
Local $sString = "Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000€" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000€" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000 €" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000 €" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00€" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00€" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00 €" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00 €" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100 €" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100€" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00 €" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00€" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2% vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2% des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland." & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland: NRW und/oder Hessen." & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03% vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3% vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03 % vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3 % vom Vorjahresumsatz" & @CRLF & _
"" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03% vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3% vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03 % vom Vorjahresumsatz" & @CRLF & _
"Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3 % vom Vorjahresumsatz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")