use strict;
my $str = 'Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100€
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland: NRW und/oder Hessen.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3 % vom Vorjahresumsatz';
my $regex = qr/(pensionsrü\w*)\s[\D]*(\d*[.,]?\d*[,.]?\d*\s?[€%])/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}