$re = '/(pensionsrü\w*)\s[\D]*(\d*[.,]?\d*[,.]?\d*\s?[€%])/mi';
$str = 'Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100€
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland: NRW und/oder Hessen.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3 % vom Vorjahresumsatz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);