using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(pensionsrü\w*)\s[\D]*(\d*[.,]?\d*[,.]?\d*\s?[€%])";
string input = @"Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100€
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00 €
Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00€
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2% des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland: NRW und/oder Hessen.
Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3% vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03 % vom Vorjahresumsatz
Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3 % vom Vorjahresumsatz";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}