import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(pensionsrü\\w*)\\s[\\D]*(\\d*[.,]?\\d*[,.]?\\d*\\s?[€%])";
final String string = "Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000€\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 10000€\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000 €\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 10000 €\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00€\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00€\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 10.000,00 €\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 10000,00 €\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 100 €\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 100€\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00 €\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 100,00€\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2% vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2% des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland.\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % des Vorjahresumsatzes, abzüglich der geltenden steuerrechtlichen Verplichtungen im jeweiligen Bundesland: NRW und/oder Hessen.\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2 % vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03% vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3% vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2,03 % vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2,3 % vom Vorjahresumsatz\n\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03% vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3% vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2.03 % vom Vorjahresumsatz\n"
+ "Die aktuellen Pensionsrückstellungen belaufen sich auf 2.3 % vom Vorjahresumsatz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}