package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|[\W])(@\w{1,20})(?:$|[\W])`)
var str = `@ih knkl @gs fsdf@ijkjdsfkl "@_dsfkoj" @sdkj-s @ℍ𝕦𝕘𝕠𝕄𝕠𝕤𝕙 s @ljbhdkj_sa3 wefd s|jhh "@nksdm" hugo@mis.com @dsf
@𝕘𝕠𝕄𝕠𝕤𝕙 dfs @! @fdsdfasdfsdfsdfsdfsdfs @last @k @jj. @sdf.sd `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}