const regex = /(?:^|[\W])(@\w{1,20})(?:$|[\W])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[\\W])(@\\w{1,20})(?:$|[\\W])', 'gm')
const str = `@ih knkl @gs fsdf@ijkjdsfkl "@_dsfkoj" @sdkj-s @ℍ𝕦𝕘𝕠𝕄𝕠𝕤𝕙 s @ljbhdkj_sa3 wefd s|jhh "@nksdm" hugo@mis.com @dsf
@𝕘𝕠𝕄𝕠𝕤𝕙 dfs @! @fdsdfasdfsdfsdfsdfsdfs @last @k @jj. @sdf.sd `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}