import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[\\W])(@\\w{1,20})(?:$|[\\W])";
final String string = "@ih knkl @gs fsdf@ijkjdsfkl \"@_dsfkoj\" @sdkj-s @ℍ𝕦𝕘𝕠𝕄𝕠𝕤𝕙 s @ljbhdkj_sa3 wefd s|jhh \"@nksdm\" hugo@mis.com @dsf\n\n"
+ "@𝕘𝕠𝕄𝕠𝕤𝕙 dfs @! @fdsdfasdfsdfsdfsdfsdfs @last @k @jj. @sdf.sd ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}