// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^|[\W])(@\w{1,20})(?:$|[\W])").unwrap();
let string = "@ih knkl @gs fsdf@ijkjdsfkl \"@_dsfkoj\" @sdkj-s @ℍ𝕦𝕘𝕠𝕄𝕠𝕤𝕙 s @ljbhdkj_sa3 wefd s|jhh \"@nksdm\" hugo@mis.com @dsf
@𝕘𝕠𝕄𝕠𝕤𝕙 dfs @! @fdsdfasdfsdfsdfsdfsdfs @last @k @jj. @sdf.sd ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}