import re
regex = re.compile(r"(?:^|[\W])(@\w{1,20})(?:$|[\W])", flags=re.MULTILINE)
test_str = ("@ih knkl @gs fsdf@ijkjdsfkl \"@_dsfkoj\" @sdkj-s @ℍ𝕦𝕘𝕠𝕄𝕠𝕤𝕙 s @ljbhdkj_sa3 wefd s|jhh \"@nksdm\" hugo@mis.com @dsf\n\n"
"@𝕘𝕠𝕄𝕠𝕤𝕙 dfs @! @fdsdfasdfsdfsdfsdfsdfs @last @k @jj. @sdf.sd ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")