using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9])\.){3}((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9]))";
string input = @"0.0.0.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}