import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((2[0-4]\\d|1\\d\\d|25[0-5]|\\d\\d|[0-9])\\.){3}((2[0-4]\\d|1\\d\\d|25[0-5]|\\d\\d|[0-9]))";
final String string = "0.0.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}