const regex = new RegExp('((2[0-4]\\d|1\\d\\d|25[0-5]|\\d\\d|[0-9])\\.){3}((2[0-4]\\d|1\\d\\d|25[0-5]|\\d\\d|[0-9]))', 'gm')
const str = `0.0.0.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}