package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9])\.){3}((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9]))`)
var str = `0.0.0.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}