$re = '/((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9])\.){3}((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9]))/m';
$str = '0.0.0.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);