re = /((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9])\.){3}((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9]))/m
str = '0.0.0.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end