// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9])\.){3}((2[0-4]\d|1\d\d|25[0-5]|\d\d|[0-9]))").unwrap();
let string = "0.0.0.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}