using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{2}/\d{2}/\d{4}[- .]+\d{2}/\d{2}/\d{4}$";
string input = @"-- these should match:
11/13/2019 - 11/13/2019
11/14/2019 11/14/2019
01/21/2019. . 11/20/2019
-- these should *not* match:
something 11/14/2019 11/14/2019 something
111111/2/3 1/1/1
1/14/2019 11/14/2019
11/14/201911/14/2019
11/13/2019 -
11/13/2019";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}