package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}/\d{2}/\d{4}[- .]+\d{2}/\d{2}/\d{4}$`)
var str = `-- these should match:
11/13/2019 - 11/13/2019
11/14/2019 11/14/2019
01/21/2019. . 11/20/2019
-- these should *not* match:
something 11/14/2019 11/14/2019 something
111111/2/3 1/1/1
1/14/2019 11/14/2019
11/14/201911/14/2019
11/13/2019 -
11/13/2019`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}