import re
regex = re.compile(r"^\d{2}/\d{2}/\d{4}[- .]+\d{2}/\d{2}/\d{4}$", flags=re.MULTILINE)
test_str = ("-- these should match:\n"
"11/13/2019 - 11/13/2019\n"
"11/14/2019 11/14/2019\n"
"01/21/2019. . 11/20/2019\n\n"
"-- these should *not* match:\n"
"something 11/14/2019 11/14/2019 something\n"
"111111/2/3 1/1/1\n"
"1/14/2019 11/14/2019\n"
"11/14/201911/14/2019\n"
"11/13/2019 - \n"
"11/13/2019")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")