import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{2}/\\d{2}/\\d{4}[- .]+\\d{2}/\\d{2}/\\d{4}$";
final String string = "-- these should match:\n"
+ "11/13/2019 - 11/13/2019\n"
+ "11/14/2019 11/14/2019\n"
+ "01/21/2019. . 11/20/2019\n\n"
+ "-- these should *not* match:\n"
+ "something 11/14/2019 11/14/2019 something\n"
+ "111111/2/3 1/1/1\n"
+ "1/14/2019 11/14/2019\n"
+ "11/14/201911/14/2019\n"
+ "11/13/2019 - \n"
+ "11/13/2019";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}