$re = '/^\d{2}/\d{2}/\d{4}[- .]+\d{2}/\d{2}/\d{4}$/m';
$str = '-- these should match:
11/13/2019 - 11/13/2019
11/14/2019 11/14/2019
01/21/2019. . 11/20/2019
-- these should *not* match:
something 11/14/2019 11/14/2019 something
111111/2/3 1/1/1
1/14/2019 11/14/2019
11/14/201911/14/2019
11/13/2019 -
11/13/2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);