// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{2}/\d{2}/\d{4}[- .]+\d{2}/\d{2}/\d{4}$").unwrap();
let string = "-- these should match:
11/13/2019 - 11/13/2019
11/14/2019 11/14/2019
01/21/2019. . 11/20/2019
-- these should *not* match:
something 11/14/2019 11/14/2019 something
111111/2/3 1/1/1
1/14/2019 11/14/2019
11/14/201911/14/2019
11/13/2019 -
11/13/2019";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}