using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hello\s+animals:\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer";
string input = @"hello
animals:
cow
cat
dog
sheep
deer ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}