import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "hello\\s+animals:\\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer";
final String string = "hello\n"
+ "animals:\n"
+ "cow\n"
+ "cat\n"
+ "dog \n"
+ "sheep\n"
+ "deer ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}