$re = '/hello\s+animals:\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer/';
$str = 'hello
animals:
cow
cat
dog
sheep
deer ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);