re = /hello\s+animals:\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer/
str = 'hello
animals:
cow
cat
dog
sheep
deer '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end