use strict;
my $str = 'hello
animals:
cow
cat
dog
sheep
deer ';
my $regex = qr/hello\s+animals:\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}