const regex = /hello\s+animals:\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hello\\s+animals:\\s+(?<!animals:)|(?P<hi>cat|cow|dog|sheep)|deer', 'g')
const str = `hello
animals:
cow
cat
dog
sheep
deer `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}