# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s*(.*?)\.)(\s*(.*?)\.)(\s*(.*?)\.)(.*)/$2\n$4\n$6\n$7/mg;t' <<< "Phrase 1.Phrase 2. Phrase 3. Phrase 4."