re = /(\s*(.*?)\.)(\s*(.*?)\.)(\s*(.*?)\.)(.*)/m
str = 'Phrase 1.Phrase 2. Phrase 3. Phrase 4.'
subst = '$2\\n$4\\n$6\\n$7'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result