const regex = /(\s*(.*?)\.)(\s*(.*?)\.)(\s*(.*?)\.)(.*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s*(.*?)\\.)(\\s*(.*?)\\.)(\\s*(.*?)\\.)(.*)', 'mg')
const str = `Phrase 1.Phrase 2. Phrase 3. Phrase 4.`;
const subst = `$2\n$4\n$6\n$7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);