// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\s*(.*?)\.)(\s*(.*?)\.)(\s*(.*?)\.)(.*)").unwrap();
let string = "Phrase 1.Phrase 2. Phrase 3. Phrase 4.";
let substitution = "$2\\n$4\\n$6\\n$7";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}