import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s*(.*?)\\.)(\\s*(.*?)\\.)(\\s*(.*?)\\.)(.*)";
final String string = "Phrase 1.Phrase 2. Phrase 3. Phrase 4.";
final String subst = "$2\\n$4\\n$6\\n$7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}