use strict;
my $str = 'Phrase 1.Phrase 2. Phrase 3. Phrase 4.';
my $regex = qr/(\s*(.*?)\.)(\s*(.*?)\.)(\s*(.*?)\.)(.*)/mp;
my $subst = '$2\\n$4\\n$6\\n$7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";